process_linux.go:297: copying bootstrap data to pipe caused \"write init-p: broken pipe\"

发表于 2022-09-09
阅读 0

介绍

介绍

福哥在给一台服务器升级docker的时候,在启动容器的时候报出了如下错误:

home/topic/2022/0909/11/969e820eeaf612a7659eceae21611ccf.png

原因

这是由于服务器操作系统的内核版本太低了,不能支持18.06及以上版本的docker-ce。

解决

解决办法,要不升级服务器操作系统的内核,要不降低docker-ce版本。

福哥采用的是比较简单的方法,降低docker-ce到18.03版本。

yum -y install docker-ce-18.03.1.ce-1.el7.centos

经过测试,发现docker-ce的18.06和18.03区别不大,果然这个选择是靠谱的~~