鬼谷子叔叔

跟福哥学编程吧~~

使用registry:2.8镜像搭建docker私有仓库registry服务
介绍介绍要学习docker首先要学会管理docker镜像,docker镜像的获取方式包括:官方拉取(pull)导出/导入(export/import)保存/加载(save/load)Dockerfile这里面大家最常用的方式还是官方拉取,但是官方镜像源的服务器在美国,我们这边下载速度没法保证。即便用了很多国内的镜像源的服务器,稳定性还...
阅读 156
CentOS7系统安装docker-ce服务
介绍介绍在现如今的微服务时代,通过源码编译安装软件的部署方式已经很有人使用了,大家都转为通过docker来部署软件或服务了。所以,福哥的TFCentOS7x64服务器也得先把docker这个基本服务安装起来,后面福哥才能在TFCentOS7x64服务器上面部署各种各样的软件或服务。今天福哥就带着大家在TFCentOS7x64上面安装d...
阅读 66
VMWare虚拟机安装CentOS-7-x86_64-2009操作系统
介绍介绍福哥为了学习Linux操作系统的使用,以及在Linux操作系统上面部署各种运行环境,打算搭建一个CentOS7的平台。福哥采用的是VMWare虚拟机作为载体搭建这个CentOS7的平台。下面福哥就带着大家一步一步地把这个CentOS7的平台搭建起来~~环境操作系统CentOS 7 x86_64 2009硬件环境VMWare 1...
阅读 59
CentOS7服务器安装图形化界面的方法【20220928】
介绍介绍福哥最近在研究达梦数据库,发现达梦数据库的Linux版本的tool下的dts不是命令行的,联系达梦技术人员得到答复是需要在Linux的图形化界面里使用这个dts工具。好吧!那就给我们的CentOS7安装一个图形化界面吧!安装查看可用版本首先我们要看看当前操作系统支持哪些版本的图形化界面库,使用如下命令可以查看,建议先改成英文后...
阅读 70
process_linux.go:297: copying bootstrap data to pipe caused \"write init-p: broken pipe\"
介绍介绍福哥在给一台服务器升级docker的时候,在启动容器的时候报出了如下错误:原因这是由于服务器操作系统的内核版本太低了,不能支持18.06及以上版本的docker-ce。解决解决办法,要不升级服务器操作系统的内核,要不降低docker-ce版本。福哥采用的是比较简单的方法,降低docker-ce到18.03版本。yum ...
阅读 98
CentOS8的yum源改为国内源
介绍介绍福哥将服务器升级到了CentOS8,发现使用CentOS7的方法不能将yum源改成163源了。后来经过一番折腾,终于成功改成了阿里云的源了。教程修正yum源需要开启baseurl并设置为vault.centos.org。sed -i 's/mirrorlist/#mirrorlist/g'&...
阅读 130
CentOS7的yum源改为国内源
介绍介绍福哥的TFLinux使用的是CentOS7操作系统,默认情况下yum源是国外的服务器,安装软件的时候会非常的慢。要解决这个问题只能把yum源改成国内的源。国内源有很多选择,福哥选择的是163源。教程更新163源首先将yum的CentOS-Base.repo改成163的。curl -o /etc/yum.re...
阅读 46
Failed to download metadata for repo 'appstream': Cannot prepare internal mirrorlist: No URLs in mirrorlist
介绍介绍福哥发现很多软件都基于高版本的libc库,如果在CentOS7上面安装的话需要升级libc才行,既然大环境已经前进了我们不能落后啊!所以福哥今后再使用CentOS系统的话会选择CentOS8这个新版本。问题现象使用CentOS8之后发现直接使用yum的话会报如下错误:Failed to set l...
阅读 84
Python-3.8.12/Modules/_ctypes/_ctypes.c:107:17: 致命错误:ffi.h:没有那个文件或目录
介绍介绍福哥最近在CentOS系统上面安装Python3.8的时候,发现编译不过去了,报了如下错误:Python-3.8.12/Modules/_ctypes/_ctypes.c:107:17: 致命错误:ffi.h:没有那个文件或目录这是耍什么幺蛾子啊??问题从表面上看是ctypes的问题,其实不然,问题出在了ffi.h这个文件找不...
阅读 1197
通过VMWare虚拟机安装CentOS 8操作系统【20210126】
介绍介绍跟福哥学习编程,无论是java,还是php,或者是asp.net,都会需要连接一些服务,包括但不限于MySQL、Redis、Memcached、Apache、Tomcat、MongoDB、ElasticSearch、Kafka等等这些软件有的有windows版本,有的只有linux版本,无论是否有windows版本,linux...
阅读 113